<!doctype html >
<!--[if IE 8]>    <html class="ie8" lang="en"> <![endif]-->
<!--[if IE 9]>    <html class="ie9" lang="en"> <![endif]-->
<!--[if gt IE 8]><!--> <html lang="en-US" prefix="og: http://ogp.me/ns#"> <!--<![endif]-->
<head>
<style>
/* Hide menu on load to prevent FOUC */
.td-header-menu-wrap-full {
    visibility: hidden;
}
#big-grid-reveal {
  visibility: hidden;
  opacity: 1;
  transition: visibility 0s linear 0s, opacity 300ms;
}
</style>
    <title>Blockchain Developers Abandon Github Following Microsoft Acquisition - Bitcoin News</title>
    <meta charset="UTF-8" />
    <meta name="viewport" content="width=device-width, initial-scale=1.0">
    <link rel="pingback" href="https://news.bitcoin.com/xmlrpc.php" />
    
    <meta property="og:image" content="https://news.bitcoin.com/wp-content/uploads/2018/06/microsoft-github.png" /><link rel="icon" type="image/png" href="https://news.bitcoin.com/wp-content/uploads/2017/07/btc_fav.png">
<!-- This site is optimized with the Yoast SEO plugin v7.1 - https://yoast.com/wordpress/plugins/seo/ -->
<meta name="description" content="Microsoft’s acquisition of open source code repository Github has provoked protest from members of the crypto community."/>
<link rel="canonical" href="https://news.bitcoin.com/blockchain-developers-abandon-github-following-microsoft-acquisition/" />
<meta property="og:locale" content="en_US" />
<meta property="og:type" content="article" />
<meta property="og:title" content="Blockchain Developers Abandon Github Following Microsoft Acquisition - Bitcoin News" />
<meta property="og:description" content="Microsoft’s acquisition of open source code repository Github has provoked protest from members of the crypto community." />
<meta property="og:url" content="https://news.bitcoin.com/blockchain-developers-abandon-github-following-microsoft-acquisition/" />
<meta property="og:site_name" content="Bitcoin News" />
<meta property="article:publisher" content="https://www.facebook.com/buy.bitcoin.news/" />
<meta property="article:tag" content="Bitcoin Core" />
<meta property="article:tag" content="Centralization" />
<meta property="article:tag" content="Development" />
<meta property="article:tag" content="github" />
<meta property="article:tag" content="gitlab" />
<meta property="article:tag" content="Microsoft" />
<meta property="article:tag" content="N-Technology" />
<meta property="article:tag" content="Open Source" />
<meta property="article:tag" content="repo" />
<meta property="article:tag" content="repository" />
<meta property="article:section" content="Blockchain" />
<meta property="article:published_time" content="2018-06-04T20:20:04-04:00" />
<meta property="article:modified_time" content="2018-06-04T13:17:16-04:00" />
<meta property="og:updated_time" content="2018-06-04T13:17:16-04:00" />
<meta property="og:image" content="https://news.bitcoin.com/wp-content/uploads/2018/06/microsoft-github.png" />
<meta property="og:image:secure_url" content="https://news.bitcoin.com/wp-content/uploads/2018/06/microsoft-github.png" />
<meta property="og:image:width" content="1600" />
<meta property="og:image:height" content="1600" />
<meta name="twitter:card" content="summary_large_image" />
<meta name="twitter:description" content="Microsoft’s acquisition of open source code repository Github has provoked protest from members of the crypto community." />
<meta name="twitter:title" content="Blockchain Developers Abandon Github Following Microsoft Acquisition - Bitcoin News" />
<meta name="twitter:site" content="@BTCTN" />
<meta name="twitter:image" content="https://news.bitcoin.com/wp-content/uploads/2018/06/microsoft-github.png" />
<meta name="twitter:creator" content="@bitcoin101" />
<script type='application/ld+json'>{"@context":"https:\/\/schema.org","@type":"Organization","url":"https:\/\/news.bitcoin.com\/","sameAs":["https:\/\/www.facebook.com\/buy.bitcoin.news\/","https:\/\/www.instagram.com\/newsbitcoincom\/","https:\/\/www.linkedin.com\/company\/bitcoin.com\/","https:\/\/www.youtube.com\/channel\/UCetxkZolEBHX47BqtZktbkg","https:\/\/www.pinterest.com\/bitcoincom00\/","https:\/\/twitter.com\/BTCTN"],"@id":"#organization","name":"Saint Bitts LLC","logo":"http:\/\/Saint%20Bitts%20LLC"}</script>
<!-- / Yoast SEO plugin. -->

<link rel='dns-prefetch' href='//widgets.bitcoin.com' />
<link rel='dns-prefetch' href='//m.servedby-buysellads.com' />
<link rel='dns-prefetch' href='//menu.cdn.bitcoindotcom.net' />
<link rel='dns-prefetch' href='//ajax.googleapis.com' />
<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="Bitcoin News &raquo; Feed" href="https://news.bitcoin.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="Bitcoin News &raquo; Comments Feed" href="https://news.bitcoin.com/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="Bitcoin News &raquo; Blockchain Developers Abandon Github Following Microsoft Acquisition Comments Feed" href="https://news.bitcoin.com/blockchain-developers-abandon-github-following-microsoft-acquisition/feed/" />
<link rel='stylesheet' id='easy_author_image-css'  href='https://news.bitcoin.com/wp-content/plugins/easy-author-image/css/easy-author-image.css?ver=4.9.6' type='text/css' media='all' />
<link rel='stylesheet' id='google-fonts-style-css'  href='https://fonts.googleapis.com/css?family=Open+Sans%3A300italic%2C400%2C400italic%2C600%2C600italic%2C700%7CRoboto%3A300%2C400%2C400italic%2C500%2C500italic%2C700%2C900&#038;ver=8.0' type='text/css' media='all' />
<link rel='stylesheet' id='js_composer_front-css'  href='https://news.bitcoin.com/wp-content/plugins/js_composer/assets/css/js_composer.min.css?ver=5.1.1' type='text/css' media='all' />
<link rel='stylesheet' id='bootstrap-css-css'  href='https://news.bitcoin.com/wp-content/plugins/bootstrap-3.3.7-plugin/css/bootstrap.min.css?ver=3.3.7' type='text/css' media='all' />
<link rel='stylesheet' id='td-theme-css'  href='https://news.bitcoin.com/wp-content/themes/Newspaper/style.css?ver=8.0' type='text/css' media='all' />
<link rel='stylesheet' id='td-theme-child-css'  href='https://news.bitcoin.com/wp-content/themes/BitcoinNews/style.css?ver=8.0c' type='text/css' media='all' />
<link rel='https://api.w.org/' href='https://news.bitcoin.com/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://news.bitcoin.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://news.bitcoin.com/wp-includes/wlwmanifest.xml" /> 
<meta name="generator" content="WordPress 4.9.6" />
<link rel='shortlink' href='https://news.bitcoin.com/?p=170366' />
<link rel="alternate" type="application/json+oembed" href="https://news.bitcoin.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fnews.bitcoin.com%2Fblockchain-developers-abandon-github-following-microsoft-acquisition%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://news.bitcoin.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fnews.bitcoin.com%2Fblockchain-developers-abandon-github-following-microsoft-acquisition%2F&#038;format=xml" />
<!--[if lt IE 9]><script src="https://html5shim.googlecode.com/svn/trunk/html5.js"></script><![endif]-->
    <meta name="generator" content="Powered by Visual Composer - drag and drop page builder for WordPress."/>
<!--[if lte IE 9]><link rel="stylesheet" type="text/css" href="https://news.bitcoin.com/wp-content/plugins/js_composer/assets/css/vc_lte_ie9.min.css" media="screen"><![endif]-->      <meta name="onesignal" content="wordpress-plugin"/>
          <link rel="manifest"
            href="https://news.bitcoin.com/wp-content/plugins/onesignal-free-web-push-notifications/sdk_files/manifest.json.php?gcm_sender_id="/>
          <script src="https://cdn.onesignal.com/sdks/OneSignalSDK.js" async></script>    <script>

      window.OneSignal = window.OneSignal || [];

      OneSignal.push( function() {
        OneSignal.SERVICE_WORKER_UPDATER_PATH = "OneSignalSDKUpdaterWorker.js.php";
        OneSignal.SERVICE_WORKER_PATH = "OneSignalSDKWorker.js.php";
        OneSignal.SERVICE_WORKER_PARAM = { scope: '/' };

        OneSignal.setDefaultNotificationUrl("https://news.bitcoin.com");
        var oneSignal_options = {};
        window._oneSignalInitOptions = oneSignal_options;

        oneSignal_options['wordpress'] = true;
oneSignal_options['appId'] = '94298d6a-6cd2-481e-bdfd-4e4a5576382d';
oneSignal_options['autoRegister'] = true;
oneSignal_options['httpPermissionRequest'] = { };
oneSignal_options['httpPermissionRequest']['enable'] = true;
oneSignal_options['welcomeNotification'] = { };
oneSignal_options['welcomeNotification']['title'] = "Bitcoin News";
oneSignal_options['welcomeNotification']['message'] = "Thanks for subscribing!";
oneSignal_options['welcomeNotification']['url'] = "https://news.bitcoin.com?utm_source=OneSignal%20Welcome&amp;utm_medium=notification&amp;utm_campaign=Push%20Notifications";
oneSignal_options['path'] = "https://news.bitcoin.com/wp-content/plugins/onesignal-free-web-push-notifications/sdk_files/";
oneSignal_options['safari_web_id'] = "web.onesignal.auto.2e1b0bc4-2845-4ea5-bb2f-59e722cf7b3c";
oneSignal_options['promptOptions'] = { };
oneSignal_options['promptOptions']['siteName'] = 'https://news.bitcoin.com';
oneSignal_options['notifyButton'] = { };
oneSignal_options['notifyButton']['enable'] = true;
oneSignal_options['notifyButton']['position'] = 'bottom-left';
oneSignal_options['notifyButton']['theme'] = 'inverse';
oneSignal_options['notifyButton']['size'] = 'medium';
oneSignal_options['notifyButton']['prenotify'] = true;
oneSignal_options['notifyButton']['displayPredicate'] = function() {
              return OneSignal.isPushNotificationsEnabled()
                      .then(function(isPushEnabled) {
                          return !isPushEnabled;
                      });
            };
oneSignal_options['notifyButton']['showCredit'] = false;
oneSignal_options['notifyButton']['text'] = {};
oneSignal_options['notifyButton']['colors'] = {};
oneSignal_options['notifyButton']['colors']['circle.background'] = '#fab915';
oneSignal_options['notifyButton']['colors']['circle.foreground'] = '#ffffff';
oneSignal_options['notifyButton']['colors']['badge.background'] = '#333333';
oneSignal_options['notifyButton']['colors']['badge.foreground'] = '#ffffff';
oneSignal_options['notifyButton']['colors']['badge.bordercolor'] = '#ffffff';
oneSignal_options['notifyButton']['colors']['pulse.color'] = '#fab915';
oneSignal_options['notifyButton']['colors']['dialog.button.background'] = '#fab915';
oneSignal_options['notifyButton']['colors']['dialog.button.background.hovering'] = '#fbc846';
oneSignal_options['notifyButton']['colors']['dialog.button.background.active'] = '#c89004';
oneSignal_options['notifyButton']['colors']['dialog.button.foreground'] = '#ffffff';
              OneSignal.init(window._oneSignalInitOptions);
                    });

      function documentInitOneSignal() {
        var oneSignal_elements = document.getElementsByClassName("OneSignal-prompt");

        var oneSignalLinkClickHandler = function(event) { OneSignal.push(['registerForPushNotifications']); event.preventDefault(); };        for(var i = 0; i < oneSignal_elements.length; i++)
          oneSignal_elements[i].addEventListener('click', oneSignalLinkClickHandler, false);
      }

      if (document.readyState === 'complete') {
           documentInitOneSignal();
      }
      else {
           window.addEventListener("load", function(event){
               documentInitOneSignal();
          });
      }
    </script>


<!-- JS generated by theme -->

<script>
    
    

	    var tdBlocksArray = []; //here we store all the items for the current page

	    //td_block class - each ajax block uses a object of this class for requests
	    function tdBlock() {
		    this.id = '';
		    this.block_type = 1; //block type id (1-234 etc)
		    this.atts = '';
		    this.td_column_number = '';
		    this.td_current_page = 1; //
		    this.post_count = 0; //from wp
		    this.found_posts = 0; //from wp
		    this.max_num_pages = 0; //from wp
		    this.td_filter_value = ''; //current live filter value
		    this.is_ajax_running = false;
		    this.td_user_action = ''; // load more or infinite loader (used by the animation)
		    this.header_color = '';
		    this.ajax_pagination_infinite_stop = ''; //show load more at page x
	    }


        // td_js_generator - mini detector
        (function(){
            var htmlTag = document.getElementsByTagName("html")[0];

            if ( navigator.userAgent.indexOf("MSIE 10.0") > -1 ) {
                htmlTag.className += ' ie10';
            }

            if ( !!navigator.userAgent.match(/Trident.*rv\:11\./) ) {
                htmlTag.className += ' ie11';
            }

            if ( /(iPad|iPhone|iPod)/g.test(navigator.userAgent) ) {
                htmlTag.className += ' td-md-is-ios';
            }

            var user_agent = navigator.userAgent.toLowerCase();
            if ( user_agent.indexOf("android") > -1 ) {
                htmlTag.className += ' td-md-is-android';
            }

            if ( -1 !== navigator.userAgent.indexOf('Mac OS X')  ) {
                htmlTag.className += ' td-md-is-os-x';
            }

            if ( /chrom(e|ium)/.test(navigator.userAgent.toLowerCase()) ) {
               htmlTag.className += ' td-md-is-chrome';
            }

            if ( -1 !== navigator.userAgent.indexOf('Firefox') ) {
                htmlTag.className += ' td-md-is-firefox';
            }

            if ( -1 !== navigator.userAgent.indexOf('Safari') && -1 === navigator.userAgent.indexOf('Chrome') ) {
                htmlTag.className += ' td-md-is-safari';
            }

            if( -1 !== navigator.userAgent.indexOf('IEMobile') ){
                htmlTag.className += ' td-md-is-iemobile';
            }

        })();




        var tdLocalCache = {};

        ( function () {
            "use strict";

            tdLocalCache = {
                data: {},
                remove: function (resource_id) {
                    delete tdLocalCache.data[resource_id];
                },
                exist: function (resource_id) {
                    return tdLocalCache.data.hasOwnProperty(resource_id) && tdLocalCache.data[resource_id] !== null;
                },
                get: function (resource_id) {
                    return tdLocalCache.data[resource_id];
                },
                set: function (resource_id, cachedData) {
                    tdLocalCache.remove(resource_id);
                    tdLocalCache.data[resource_id] = cachedData;
                }
            };
        })();

    
    
var td_viewport_interval_list=[{"limitBottom":767,"sidebarWidth":228},{"limitBottom":1018,"sidebarWidth":300},{"limitBottom":1140,"sidebarWidth":324}];
var tds_general_modal_image="yes";
var td_ajax_url="https:\/\/news.bitcoin.com\/wp-admin\/admin-ajax.php?td_theme_name=Newspaper&v=8.0";
var td_get_template_directory_uri="https:\/\/news.bitcoin.com\/wp-content\/themes\/Newspaper";
var tds_snap_menu="smart_snap_always";
var tds_logo_on_sticky="show";
var tds_header_style="";
var td_please_wait="Please wait...";
var td_email_user_pass_incorrect="User or password incorrect!";
var td_email_user_incorrect="Email or username incorrect!";
var td_email_incorrect="Email incorrect!";
var tds_more_articles_on_post_enable="";
var tds_more_articles_on_post_time_to_wait="";
var tds_more_articles_on_post_pages_distance_from_top=0;
var tds_theme_color_site_wide="#fab915";
var tds_smart_sidebar="enabled";
var tdThemeName="Newspaper";
var td_magnific_popup_translation_tPrev="Previous (Left arrow key)";
var td_magnific_popup_translation_tNext="Next (Right arrow key)";
var td_magnific_popup_translation_tCounter="%curr% of %total%";
var td_magnific_popup_translation_ajax_tError="The content from %url% could not be loaded.";
var td_magnific_popup_translation_image_tError="The image #%curr% could not be loaded.";
var td_ad_background_click_link="";
var td_ad_background_click_target="";
</script>

<!-- Google Tag Manager -->
<script>(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':
new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],
j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src=
'https://www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);
})(window,document,'script','dataLayer','GTM-5N6TL56');</script>
<!-- End Google Tag Manager --><script type="application/ld+json">
                        {
                            "@context": "http://schema.org",
                            "@type": "BreadcrumbList",
                            "itemListElement": [{
                            "@type": "ListItem",
                            "position": 1,
                                "item": {
                                "@type": "WebSite",
                                "@id": "https://news.bitcoin.com/",
                                "name": "Home"                                               
                            }
                        },{
                            "@type": "ListItem",
                            "position": 2,
                                "item": {
                                "@type": "WebPage",
                                "@id": "https://news.bitcoin.com/category/technology-security/",
                                "name": "Technology &amp; Security"
                            }
                        },{
                            "@type": "ListItem",
                            "position": 3,
                                "item": {
                                "@type": "WebPage",
                                "@id": "https://news.bitcoin.com/category/technology-security/blockchain/",
                                "name": "Blockchain"                                
                            }
                        },{
                            "@type": "ListItem",
                            "position": 4,
                                "item": {
                                "@type": "WebPage",
                                "@id": "https://news.bitcoin.com/blockchain-developers-abandon-github-following-microsoft-acquisition/",
                                "name": "Blockchain Developers Abandon Github Following Microsoft Acquisition"                                
                            }
                        }    ]
                        }
                       </script><noscript><style type="text/css"> .wpb_animate_when_almost_visible { opacity: 1; }</style></noscript>	<!-- BuySellAds PRO Code -->
    <script type="text/javascript">(function(){var bsa = document.createElement('script');bsa.type = 'text/javascript';bsa.async = true;bsa.src = '//cdn.buysellads.com/ac/pro.js';document.getElementsByTagName('head')[0].appendChild(bsa);})();</script>
    <!-- End BuySellAds PRO Ad Code -->
</head>

<body class="post-template-default single single-post postid-170366 single-format-standard blockchain-developers-abandon-github-following-microsoft-acquisition global-block-template-1 td-magazine single_template_2 wpb-js-composer js-comp-ver-5.1.1 vc_responsive td-full-layout" itemscope="itemscope" itemtype="https://schema.org/WebPage">
<!-- Google Tag Manager (noscript) -->
<noscript><iframe src="https://www.googletagmanager.com/ns.html?id=GTM-5N6TL56"
height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript>
<!-- End Google Tag Manager (noscript) -->

        <div class="td-scroll-up"><i class="td-icon-menu-up"></i></div>
    
    <div class="td-menu-background"></div>
<div id="td-mobile-nav">
    <div class="td-mobile-container">
        <!-- mobile menu top section -->
        <div class="td-menu-socials-wrap">
            <!-- socials -->
            <div class="td-menu-socials">
                
        <span class="td-social-icon-wrap">
            <a target="_blank" href="http://facebook.com/buy.bitcoin.news" title="Facebook">
                <i class="td-icon-font td-icon-facebook"></i>
            </a>
        </span>
        <span class="td-social-icon-wrap">
            <a target="_blank" href="https://www.instagram.com/bitcoin.com_official/" title="Instagram">
                <i class="td-icon-font td-icon-instagram"></i>
            </a>
        </span>
        <span class="td-social-icon-wrap">
            <a target="_blank" href="https://news.bitcoin.com/feed" title="RSS">
                <i class="td-icon-font td-icon-rss"></i>
            </a>
        </span>
        <span class="td-social-icon-wrap">
            <a target="_blank" href="http://twitter.com/BTCTN" title="Twitter">
                <i class="td-icon-font td-icon-twitter"></i>
            </a>
        </span>
        <span class="td-social-icon-wrap">
            <a target="_blank" href="https://telegram.me/www_Bitcoin_com" title="Telegram">
                <i class="td-icon-font td-icon-telegram"></i>
            </a>
        </span>
        <span class="td-social-icon-wrap">
            <a target="_blank" href="https://www.youtube.com/channel/UCetxkZolEBHX47BqtZktbkg" title="Youtube">
                <i class="td-icon-font td-icon-youtube"></i>
            </a>
        </span>            </div>
            <!-- close button -->
            <div class="td-mobile-close">
                <a href="#"><i class="td-icon-close-mobile"></i></a>
            </div>
        </div>

        <!-- login section -->
        
        <!-- menu section -->
        <div class="td-mobile-content">
            <div class="menu-main-menu-container"><ul id="menu-main-menu" class="td-mobile-main-menu"><li id="menu-item-52574" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-home menu-item-first menu-item-52574"><a href="https://news.bitcoin.com/">News</a></li>
<li id="menu-item-52573" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-52573"><a href="https://news.bitcoin.com/op-ed/">Op-Ed</a></li>
<li id="menu-item-52572" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-52572"><a href="https://news.bitcoin.com/submit-press-release/">Submit a Press Release</a></li>
<li id="menu-item-52571" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-52571"><a href="https://news.bitcoin.com/press-releases/">Press Releases</a></li>
<li id="menu-item-52576" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-52576"><a href="https://news.bitcoin.com/about-bitcoin-news/">About</a></li>
<li id="menu-item-52575" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-52575"><a href="https://news.bitcoin.com/advertise/">Advertise</a></li>
<li id="menu-item-61350" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-61350"><a href="https://news.bitcoin.com/the-satoshi-revolution-by-wendy-mcelroy/">The Satoshi Revolution</a></li>
</ul></div>        </div>
    </div>

    <!-- register/login section -->
    </div>    <div class="td-search-background"></div>
<div class="td-search-wrap-mob">
	<div class="td-drop-down-search" aria-labelledby="td-header-search-button">
		<form method="get" class="td-search-form" action="https://news.bitcoin.com/">
			<!-- close button -->
			<div class="td-search-close">
				<a href="#"><i class="td-icon-close-mobile"></i></a>
			</div>
			<div role="search" class="td-search-input">
				<span>Search</span>
				<input id="td-header-search-mob" type="text" value="" name="s" autocomplete="off" />
			</div>
		</form>
		<div id="td-aj-search-mob"></div>
	</div>
</div>    
    
    <div id="td-outer-wrap" class="td-theme-wrap">
    
        <!--
Header style 1
-->

<div class="btc-submenu td-header-wrap td-header-style-1">
    
    <div class="td-banner-wrap-full td-logo-wrap-full td-container-wrap ">
    
    <div class="towers-bch">
      <svg viewBox="0 0 700 500" class="chart-bch" id="chart-line-bch">   
        <polyline id="chart-poly-bch"           
          points="        
            42,180        
            125,180        
            215,180        
            310,180        
            400,180       
            477,180        
            580,180"
        >
        <animate id="line-points-bch" fill="freeze" begin="indefinite" attributeName="points" dur="1s" to="42,300 125,300 215,300 310,300 400,300 477,300 580,300" />
        </polyline>
        
      </svg>    
        
        <div class="tower-holder">          
          <img id="bcc0" src="/wp-content/uploads/2018/01/b5gold.png">          
          <p class="caysh-meta" id="caysh-meta-1"></p>
          <p class="day-meta" id="caysh-day-meta-1"></p>
        </div>
        
        <div class="tower-holder">          
          <img id="bcc1" src="/wp-content/uploads/2018/01/b6gold.png">          
          <p class="caysh-meta" id="caysh-meta-2"></p>
          <p class="day-meta" id="caysh-day-meta-2"></p> 
        </div>
        
        <div class="tower-holder">         
          <img id="bcc2" src="/wp-content/uploads/2018/01/b2gold.png">         
          <p class="caysh-meta" id="caysh-meta-3"></p>
          <p class="day-meta" id="caysh-day-meta-3"></p> 
        </div>
        
        <div class="tower-holder">                         
          <img id="bcc3" src="/wp-content/uploads/2018/01/b3gold.png">          
          <p class="caysh-meta" id="caysh-meta-4"></p>
          <p class="day-meta" id="caysh-day-meta-4"></p>   
        </div>
        
        <div class="tower-holder">            
          <img id="bcc4" src="/wp-content/uploads/2018/01/b1gold.png">         
          <p class="caysh-meta" id="caysh-meta-5"></p>
          <p class="day-meta" id="caysh-day-meta-5"></p>   
        </div>
        
        <div class="tower-holder">              
          <img id="bcc5" src="/wp-content/uploads/2018/01/b4gold.png">          
          <p class="caysh-meta" id="caysh-meta-6"></p>
          <p class="day-meta" id="caysh-day-meta-6"></p>  
        </div>
        
        <div class="tower-holder">              
          <img id="bcc6" src="/wp-content/uploads/2018/01/b6gold.png">         
          <p class="caysh-meta" id="caysh-meta-now"></p>
          <p class="day-meta" id="caysh-day-meta-now"></p>           
        </div>
        
        <div class="tower-holder">  
          <img style="visibility: hidden;" id="b7" src="/wp-content/uploads/2018/01/b1gold.png">
          <p class="caysh-meta" id="caysh-meta-label">$BCH</p>                    
        </div>
    </div>
    
    
        <div class="td-container td-header-row td-header-header" >
        
          
            <div class="td-header-sp-logo">
                        <a class="td-main-logo" href="https://news.bitcoin.com/">
            <img class="td-retina-data" data-retina="https://news.bitcoin.com/wp-content/uploads/2017/07/NEWS_desktop_retina.png" src="https://news.bitcoin.com/wp-content/uploads/2017/07/NEWS_desktop.png" alt=""/>
            <span class="td-visual-hidden">Bitcoin News</span>
        </a>
                </div>
            <div id="page-top-subtitle">
                Jun 5, 2018            </div>

            
            
        
        </div>
    
    
    <div class="towers">
      <svg viewBox="0 0 700 500" class="chart" id="chart-line">   
        <polyline id="chart-poly"           
          points="        
            42,180        
            125,180        
            215,180        
            310,180        
            400,180       
            477,180        
            580,180"
        >
        <animate id="line-points" fill="freeze" begin="indefinite" attributeName="points" dur="1s" to="42,180 125,180 215,180 310,180 400,180 477,180 580,180" />
        </polyline>
        
      </svg>    
        
        <div class="tower-holder">
          <img id="b0" src="/wp-content/uploads/2018/01/b1lightgrey.png">          
          <p class="price-meta" id="price-meta-1"></p>          
          <p class="day-meta" id="day-meta-1"></p>
        </div>
        
        <div class="tower-holder">
          <img id="b1" src="/wp-content/uploads/2018/01/b2lightgrey.png">          
          <p class="price-meta" id="price-meta-2"></p>          
          <p class="day-meta" id="day-meta-2"></p> 
        </div>
        
        <div class="tower-holder">
          <img id="b2" src="/wp-content/uploads/2018/01/b3lightgrey.png">          
          <p class="price-meta" id="price-meta-3"></p>          
          <p class="day-meta" id="day-meta-3"></p> 
        </div>
        
        <div class="tower-holder">               
          <img id="b3" src="/wp-content/uploads/2018/01/b4lightgrey.png">          
          <p class="price-meta" id="price-meta-4"></p>         
          <p class="day-meta" id="day-meta-4"></p>   
        </div>
        
        <div class="tower-holder">    
          <img id="b4" src="/wp-content/uploads/2018/01/b3lightgrey.png">          
          <p class="price-meta" id="price-meta-5"></p>          
          <p class="day-meta" id="day-meta-5"></p>   
        </div>
        
        <div class="tower-holder">     
          <img id="b5" src="/wp-content/uploads/2018/01/b6lightgrey.png">          
          <p class="price-meta" id="price-meta-6"></p>          
          <p class="day-meta" id="day-meta-6"></p>  
        </div>
        
        <div class="tower-holder">    
          <img id="b6" src="/wp-content/uploads/2018/01/b1lightgrey.png">         
          <p class="price-meta" id="price-meta-now"></p>          
          <p class="day-meta" id="day-meta-now"></p>           
        </div>
        
        <div class="tower-holder">  
          <img style="visibility: hidden;" id="b7" src="/wp-content/uploads/2018/01/b1lightgrey.png">
          <p class="price-meta" id="price-meta-label">$BTC</p>                           
        </div>
    </div>
    
    </div>

    <div class="td-header-menu-wrap-full td-container-wrap ">
        
        <div class="td-header-menu-wrap td-header-gradient">
           
            <div class="td-container td-header-row td-header-main-menu">
                

<div id="td-header-menu" role="navigation">
    <div id="td-top-mobile-toggle"><a href="#"><i class="td-icon-font td-icon-mobile"></i></a></div>
    <div class="td-main-menu-logo td-logo-in-header">
        		<a class="td-mobile-logo td-sticky-mobile" href="https://news.bitcoin.com/">
			<img class="td-retina-data" data-retina="https://news.bitcoin.com/wp-content/uploads/2017/07/NEWS_retina_mobile.png" src="https://news.bitcoin.com/wp-content/uploads/2017/07/NEWS_mobile.png" alt=""/>
		</a>
			<a class="td-header-logo td-sticky-mobile" href="https://news.bitcoin.com/">
			<img class="td-retina-data" data-retina="https://news.bitcoin.com/wp-content/uploads/2017/07/NEWS_desktop_retina.png" src="https://news.bitcoin.com/wp-content/uploads/2017/07/NEWS_desktop.png" alt=""/>
		</a>
	    </div>
    <div class="menu-main-menu-container"><ul id="menu-main-menu-1" class="sf-menu"><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-home menu-item-first td-menu-item td-normal-menu menu-item-52574"><a href="https://news.bitcoin.com/">News</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-52573"><a href="https://news.bitcoin.com/op-ed/">Op-Ed</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-52572"><a href="https://news.bitcoin.com/submit-press-release/">Submit a Press Release</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-52571"><a href="https://news.bitcoin.com/press-releases/">Press Releases</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-52576"><a href="https://news.bitcoin.com/about-bitcoin-news/">About</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-52575"><a href="https://news.bitcoin.com/advertise/">Advertise</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-61350"><a href="https://news.bitcoin.com/the-satoshi-revolution-by-wendy-mcelroy/">The Satoshi Revolution</a></li>
</ul></div>
    
</div>

<!-- Social -->





<div class="td-search-wrapper">
    <div id="td-top-search">

        <!-- Search -->
        
        <div class="header-search-wrap">
            <div class="dropdown header-search">
                <div id="wtf">
                <a id="td-header-search-button" href="#" role="button" class="dropdown-toggle " data-toggle="dropdown"><i class="td-icon-search"></i></a>          
         
    
    
        <span class="td-social-icon-wrap">
            <a target="_blank" href="http://facebook.com/buy.bitcoin.news" title="Facebook">
                <i class="td-icon-font td-icon-facebook"></i>
            </a>
        </span>
        <span class="td-social-icon-wrap">
            <a target="_blank" href="https://www.instagram.com/bitcoin.com_official/" title="Instagram">
                <i class="td-icon-font td-icon-instagram"></i>
            </a>
        </span>
        <span class="td-social-icon-wrap">
            <a target="_blank" href="https://news.bitcoin.com/feed" title="RSS">
                <i class="td-icon-font td-icon-rss"></i>
            </a>
        </span>
        <span class="td-social-icon-wrap">
            <a target="_blank" href="http://twitter.com/BTCTN" title="Twitter">
                <i class="td-icon-font td-icon-twitter"></i>
            </a>
        </span>
        <span class="td-social-icon-wrap">
            <a target="_blank" href="https://telegram.me/www_Bitcoin_com" title="Telegram">
                <i class="td-icon-font td-icon-telegram"></i>
            </a>
        </span>
        <span class="td-social-icon-wrap">
            <a target="_blank" href="https://www.youtube.com/channel/UCetxkZolEBHX47BqtZktbkg" title="Youtube">
                <i class="td-icon-font td-icon-youtube"></i>
            </a>
        </span>    
      </div>
                <a id="td-header-search-button-mob" href="#" role="button" class="dropdown-toggle " data-toggle="dropdown"><i class="td-icon-search"></i></a>
            </div>
        </div>
    </div>
</div>

<div class="header-search-wrap">
	<div class="dropdown header-search">
		<div class="td-drop-down-search" aria-labelledby="td-header-search-button">
			<form method="get" class="td-search-form" action="https://news.bitcoin.com/">
				<div role="search" class="td-head-form-search-wrap">
					<input id="td-header-search" type="text" value="" name="s" autocomplete="off" /><input class="wpb_button wpb_btn-inverse btn" type="submit" id="td-header-search-top" value="Search" />
				</div>
			</form>
			<div id="td-aj-search"></div>
		</div>
	</div>
</div>

            </div>
        </div>
    </div>

</div>
<div class="td-main-content-wrap td-container-wrap">
    <div class="td-container td-post-template-2">
       <style type="text/css">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</style><div id="ajax-load-more" class="ajax-load-more-wrap infinite fading-circles"  data-alm-id="" data-canonical-url="https://news.bitcoin.com/blockchain-developers-abandon-github-following-microsoft-acquisition/" data-slug="blockchain-developers-abandon-github-following-microsoft-acquisition" data-post-id="170366" ><div class="alm-listing alm-ajax" data-previous-post="true" data-previous-post-id="170366" data-previous-post-excluded-terms="341" data-previous-post-title-template="" data-previous-post-site-title="Bitcoin News" data-previous-post-site-tagline="Daily Bitcoin News" data-previous-post-scroll="false" data-previous-post-scroll-speed="500" data-previous-post-scrolltop="30" data-previous-post-controls="1" data-previous-post-pageview="true" data-repeater="default" data-post-type="post" data-sticky-posts="" data-post-format="" data-category="" data-category-not-in="" data-tag="" data-tag-not-in="" data-taxonomy="" data-taxonomy-terms="" data-taxonomy-operator="" data-taxonomy-relation="" data-meta-key="" data-meta-value="" data-meta-compare="" data-meta-relation="" data-meta-type="" data-year="" data-month="" data-day="" data-author="" data-post-in="" data-post-not-in="" data-exclude="" data-search="" data-custom-args="" data-post-status="" data-order="DESC" data-orderby="date" data-offset="0" data-posts-per-page="1" data-lang="" data-scroll="true" data-scroll-distance="100" data-scroll-container="" data-max-pages="0" data-pause-override="false" data-pause="false" data-button-label="Older Posts" data-destroy-after="" data-transition="slide" data-images-loaded="false"><div class="alm-reveal alm-previous-post post-170366" data-url="https://news.bitcoin.com/blockchain-developers-abandon-github-following-microsoft-acquisition/" data-title="Blockchain Developers Abandon Github Following Microsoft Acquisition" data-id="170366" data-page="0"><script>
if (window.tdAnimationStack) {
window.tdAnimationStack.reinit();
}
// update the post date after infinite scroll load
// dateLive()
</script>
<article id="post-170366" class="post-170366 post type-post status-publish format-standard has-post-thumbnail hentry category-blockchain tag-bitcoin-core tag-centralization tag-development tag-github tag-gitlab tag-microsoft tag-n-technology tag-open-source tag-repo tag-repository" itemscope itemtype="https://schema.org/Article">
            <div class="td-pb-row">
                <div class="td-pb-span12">
                    <div class="td-post-header">
                        

                                                
                        <header class="td-post-title">
                         
                        </header>
                        
                    </div>
                </div>
            </div> <!-- /.td-pb-row -->

            <div class="td-pb-row">
                                            <div class="td-pb-span8 td-main-content" role="main">
                                <div class="td-ss-main-content">
                                        
     

        

        <div class="td-post-content"> 
            
            <div class="home td_module_mx19 td_module_wrap td-animation-stack td-meta-info-hide td-big-grid-post-2 td-big-grid-post">
              <div class="td-module-image">                
                <div class="td-post-featured-image"><a href="https://news.bitcoin.com/wp-content/uploads/2018/06/microsoft-github.png" data-caption=""><img width="1068" height="1068" class="entry-thumb td-modal-image" src="https://news.bitcoin.com/wp-content/uploads/2018/06/microsoft-github-1068x1068.png" srcset="https://news.bitcoin.com/wp-content/uploads/2018/06/microsoft-github-1068x1068.png 1068w, https://news.bitcoin.com/wp-content/uploads/2018/06/microsoft-github.png 2136w" sizes="(-webkit-min-device-pixel-ratio: 2) 2136px, (min-resolution: 192dpi) 2136px, 1068px" alt="Blockchain Developers Abandon Github Following Microsoft Acquisition" title="Blockchain Developers Abandon Github Following Microsoft Acquisition"/></a></div>              </div>
              
              <div class="td-post-category top-left-label btc-post-meta td-post-title">
              
                Blockchain  
              </div>
              
                <div class="td-meta-info-container td-btc-posts">                
                  <div class="td-meta-align">  
                    <div class="td-big-grid-meta">   
                      <div class="btc-post-meta td-post-title td-post-author-name">
                        21 hours ago <div class='tstamp' style='display: none' data-ts=1528158004></div>   |
                          <div class="td-post-author-name"><div class="td-author-by">By</div> <a href="https://news.bitcoin.com/author/kaisedgwick/">Kai Sedgwick</a><div class="td-author-line"> - </div> </div> |
                          <div class="td-post-views"><i class="td-icon-views"></i><span class="td-nr-views-170366">6509</span></div>                          <div class="td-post-comments hidden"><span><i class="td-icon-commenting"></i><span class="disqus-comment-count" data-disqus-identifier=""></span></span></div>                      </div>                    
                      <div class="td-module-title td-btc-posts-title">
                        <h1 class="entry-title">Blockchain Developers Abandon Github Following Microsoft Acquisition</h1>                      </div>                        
                    </div>
                  </div>                    
                </div>    
            </div>            

            <div class="td-a-rec td-a-rec-id-content_top  "><!-- BuySellAds PRO Zone Code (News Post Top Leaderboard) -->
<div id="bsap_2535" class="bsaPROrocks" data-serve="CKYD62Q7" data-segment-placement="news"></div>
<!-- End BuySellAds PRO Zone Code -->
</div><p><strong>Microsoft’s acquisition of open source code repository Github has provoked protest from members of the crypto community. Developers of bitcoin core and other blockchains have expressed disquiet at the corporate takeover, with several stating their intent to migrate to an alternative platform at the earliest possible convenience.</strong></p>
<p><em><span style="font-weight: 400;"><strong>Also read:</strong> <a href="https://news.bitcoin.com/crypto-point-of-sale-devices-begin-roll-out-in-indonesia-despite-ban/" target="_blank" rel="noopener">Crypto Point-of-Sale Devices Begin Roll-Out in Indonesia Despite Ban</a></span></em></p>
<h2 style="text-align: center;"><span style="font-weight: 400;">Github Buyout Causes Controversy</span></h2>
<p><span style="font-weight: 400;"><img class="alignright wp-image-170370" src="https://news.bitcoin.com/wp-content/uploads/2018/06/880593_media_512x512-300x300.png" alt="Blockchain Developers Abandon Github Following Microsoft Acquisition" width="241" height="241" srcset="https://news.bitcoin.com/wp-content/uploads/2018/06/880593_media_512x512-300x300.png 300w, https://news.bitcoin.com/wp-content/uploads/2018/06/880593_media_512x512-150x150.png 150w, https://news.bitcoin.com/wp-content/uploads/2018/06/880593_media_512x512-768x768.png 768w, https://news.bitcoin.com/wp-content/uploads/2018/06/880593_media_512x512-1024x1024.png 1024w, https://news.bitcoin.com/wp-content/uploads/2018/06/880593_media_512x512-696x696.png 696w, https://news.bitcoin.com/wp-content/uploads/2018/06/880593_media_512x512-1392x1392.png 1392w, https://news.bitcoin.com/wp-content/uploads/2018/06/880593_media_512x512-1068x1068.png 1068w, https://news.bitcoin.com/wp-content/uploads/2018/06/880593_media_512x512-420x420.png 420w, https://news.bitcoin.com/wp-content/uploads/2018/06/880593_media_512x512.png 1600w" sizes="(max-width: 241px) 100vw, 241px" />Microsoft’s acquisition of Github is a good bit of business for both parties, but the news has not been well received by the community who rely on the popular code repository. Github has yet to turn a profit and has been without a CEO for the past nine months. Microsoft’s arrival eases Github’s financial worries and provides stability moving forwards. The technology giant is believed to be interested in Github as a means of gauging what programmers are creating and ascertaining what’s trending.</span></p>
<p><span style="font-weight: 400;">For bitcoin developers, raised in a community which prizes open source standards and freedom from corporate control, Microsoft’s involvement sticks in the craw. A number of developers have now led calls to abandon the platform and move to an alternative repository, with Gitlab appearing to be the biggest beneficiary so far. It’s released data showing a flurry of repositories migrating to its platform.</span></p>
<p><img class="aligncenter size-large wp-image-170376" src="https://news.bitcoin.com/wp-content/uploads/2018/06/gitlab-import-1024x333.png" alt="Blockchain Developers Abandon Github Following Microsoft Acquisition" width="696" height="226" srcset="https://news.bitcoin.com/wp-content/uploads/2018/06/gitlab-import-1024x333.png 1024w, https://news.bitcoin.com/wp-content/uploads/2018/06/gitlab-import-300x98.png 300w, https://news.bitcoin.com/wp-content/uploads/2018/06/gitlab-import-768x250.png 768w, https://news.bitcoin.com/wp-content/uploads/2018/06/gitlab-import-696x226.png 696w, https://news.bitcoin.com/wp-content/uploads/2018/06/gitlab-import-1392x453.png 1392w, https://news.bitcoin.com/wp-content/uploads/2018/06/gitlab-import-1068x347.png 1068w, https://news.bitcoin.com/wp-content/uploads/2018/06/gitlab-import-1291x420.png 1291w, https://news.bitcoin.com/wp-content/uploads/2018/06/gitlab-import.png 1408w" sizes="(max-width: 696px) 100vw, 696px" /></p>
<h2 style="text-align: center;"><span style="font-weight: 400;">The Beginning of the End for Github?</span></h2>
<p><span style="font-weight: 400;">Bitcoin core developer Wladimir van der Laan is </span><a href="https://twitter.com/orionwl/status/1003549916462047232" target="_blank" rel="noopener"><span style="font-weight: 400;">of the opinion</span></a><span style="font-weight: 400;"> that the BTC repository should move, asserting “I expect this is the beginning of a long painful road of GH toward obsolescence”. While there is nothing to suggest, at this stage, that Microsoft is posed to start hiking fees and plundering data, its ownership of a community that prides itself on decentralization is hard for many to stomach.</span></p>
<p><img class="aligncenter size-full wp-image-170369" src="https://news.bitcoin.com/wp-content/uploads/2018/06/github-microsoft.jpg" alt="Blockchain Developers Abandon Github Following Microsoft Acquisition" width="750" height="500" srcset="https://news.bitcoin.com/wp-content/uploads/2018/06/github-microsoft.jpg 750w, https://news.bitcoin.com/wp-content/uploads/2018/06/github-microsoft-300x200.jpg 300w, https://news.bitcoin.com/wp-content/uploads/2018/06/github-microsoft-696x464.jpg 696w, https://news.bitcoin.com/wp-content/uploads/2018/06/github-microsoft-630x420.jpg 630w" sizes="(max-width: 750px) 100vw, 750px" /></p>
<p><span style="font-weight: 400;">More than 1,000 tweets have been sent with the #movingtogitlab hashtag, and the company has offered a </span><a href="https://about.gitlab.com/2018/06/03/movingtogitlab/" target="_blank" rel="noopener"><span style="font-weight: 400;">75% discount</span></a><span style="font-weight: 400;"> on its pricing plan to sweeten the deal and hasten the exodus from Github. Other developers have suggested </span><a href="https://keybase.io/" target="_blank" rel="noopener"><span style="font-weight: 400;">Keybase</span></a><span style="font-weight: 400;">, which provides private repositories that are encrypted, with the bitcoin blockchain used to anchor identities. It’s too early to tell whether Microsoft’s latest purchase will mark the demise of Github or usher in a new era, but early signs point to the former. Those intent on leaving the web’s largest code repository are doing so out of principle. Github, under its new owners, has become the antithesis of everything they stand for.</span></p>
<p><em><strong>Do you think cryptocurrency projects should move away from Github now it&#8217;s under Microsoft&#8217;s control? Let us know in the comments section below.</strong></em></p>
<hr />
<p><em>Images courtesy of Shutterstock, and <a href="https://twitter.com/mammadori/status/1003549177404645376" target="_blank" rel="noopener">Twitter</a>.</em></p>
<hr />
<p><i>Need to calculate your bitcoin holdings? Check our <a href="http://tools.bitcoin.com/" target="_blank" rel="noopener">tools</a> section.</i></p>
        </div>


        <footer>
                        
            <div class="td-post-source-tags">
                                <ul class="td-tags td-post-small-box clearfix"><li><span>TAGS</span></li><li><a href="https://news.bitcoin.com/tag/bitcoin-core/">Bitcoin Core</a></li><li><a href="https://news.bitcoin.com/tag/centralization/">Centralization</a></li><li><a href="https://news.bitcoin.com/tag/development/">Development</a></li><li><a href="https://news.bitcoin.com/tag/github/">github</a></li><li><a href="https://news.bitcoin.com/tag/gitlab/">gitlab</a></li><li><a href="https://news.bitcoin.com/tag/microsoft/">Microsoft</a></li><li><a href="https://news.bitcoin.com/tag/n-technology/">N-Technology</a></li><li><a href="https://news.bitcoin.com/tag/open-source/">Open Source</a></li><li><a href="https://news.bitcoin.com/tag/repo/">repo</a></li><li><a href="https://news.bitcoin.com/tag/repository/">repository</a></li></ul>            </div>

            <div class="td-post-sharing td-post-sharing-bottom "><span class="td-post-share-title">SHARE</span>
            <div class="td-default-sharing">
	            <a class="td-social-sharing-buttons td-social-facebook" href="https://www.facebook.com/sharer.php?u=https%3A%2F%2Fnews.bitcoin.com%2Fblockchain-developers-abandon-github-following-microsoft-acquisition%2F" onclick="window.open(this.href, 'mywin','left=50,top=50,width=600,height=350,toolbar=0'); return false;"><i class="td-icon-facebook"></i><div class="td-social-but-text">Facebook</div></a>
	            <a class="td-social-sharing-buttons td-social-twitter" href="https://twitter.com/intent/tweet?text=Blockchain+Developers+Abandon+Github+Following+Microsoft+Acquisition&url=https%3A%2F%2Fnews.bitcoin.com%2Fblockchain-developers-abandon-github-following-microsoft-acquisition%2F&via=BTCTN"><i class="td-icon-twitter"></i><div class="td-social-but-text">Twitter</div></a>
	            <a class="td-social-sharing-buttons td-social-google" href="https://plus.google.com/share?url=https://news.bitcoin.com/blockchain-developers-abandon-github-following-microsoft-acquisition/" onclick="window.open(this.href, 'mywin','left=50,top=50,width=600,height=350,toolbar=0'); return false;"><i class="td-icon-googleplus"></i></a>
	            <a class="td-social-sharing-buttons td-social-pinterest" href="https://pinterest.com/pin/create/button/?url=https://news.bitcoin.com/blockchain-developers-abandon-github-following-microsoft-acquisition/&amp;media=https://news.bitcoin.com/wp-content/uploads/2018/06/microsoft-github.png&description=Microsoft’s acquisition of open source code repository Github has provoked protest from members of the crypto community." onclick="window.open(this.href, 'mywin','left=50,top=50,width=600,height=350,toolbar=0'); return false;"><i class="td-icon-pinterest"></i></a>
	            <a class="td-social-sharing-buttons td-social-whatsapp" href="whatsapp://send?text=Blockchain+Developers+Abandon+Github+Following+Microsoft+Acquisition%20-%20https%3A%2F%2Fnews.bitcoin.com%2Fblockchain-developers-abandon-github-following-microsoft-acquisition%2F" ><i class="td-icon-whatsapp"></i></a>
            </div></div>                        <div class="author-box-wrap"><a href="https://news.bitcoin.com/author/kaisedgwick/"><img class="avatar avatar-96 photo" width="64" height="64" src="https://news.bitcoin.com/wp-content/uploads/2017/11/crop-903x1024.jpeg"/></a><div class="desc"><div class="td-author-name vcard author"><span class="fn"><a href="https://news.bitcoin.com/author/kaisedgwick/">Kai Sedgwick</a></span></div><div class="td-author-description">Kai's been playing with words for a living since 2009 and bought his first bitcoin at $19. It's long gone. He's previously written white papers for blockchain startups and is especially interested in P2P exchanges and DNMs.</div><div class="td-author-social">
        <span class="td-social-icon-wrap">
            <a target="_blank" href="https://twitter.com/bitcoin101" title="Twitter">
                <i class="td-icon-font td-icon-twitter"></i>
            </a>
        </span></div><div class="clearfix"></div></div></div>	        <span style="display: none;" itemprop="author" itemscope itemtype="https://schema.org/Person"><meta itemprop="name" content="Kai Sedgwick"></span><meta itemprop="datePublished" content="2018-06-04T20:20:04+00:00"><meta itemprop="dateModified" content="2018-06-04T13:17:16+00:00"><meta itemscope itemprop="mainEntityOfPage" itemType="https://schema.org/WebPage" itemid="https://news.bitcoin.com/blockchain-developers-abandon-github-following-microsoft-acquisition/"/><span style="display: none;" itemprop="publisher" itemscope itemtype="https://schema.org/Organization"><span style="display: none;" itemprop="logo" itemscope itemtype="https://schema.org/ImageObject"><meta itemprop="url" content="https://news.bitcoin.com/wp-content/uploads/2017/07/NEWS_desktop.png"></span><meta itemprop="name" content="Bitcoin News"></span><meta itemprop="headline " content="Blockchain Developers Abandon Github Following Microsoft Acquisition"><span style="display: none;" itemprop="image" itemscope itemtype="https://schema.org/ImageObject"><meta itemprop="url" content="https://news.bitcoin.com/wp-content/uploads/2018/06/microsoft-github.png"><meta itemprop="width" content="1600"><meta itemprop="height" content="1600"></span>        </footer>

    
                                <div class="alm-disqus" data-disqus-shortname="bitcoincom"></div>
                                </div>
                            </div>
                            <div class="td-pb-span4 td-main-sidebar" role="complementary">
                                <div class="td-ss-main-sidebar">
                                    <aside class="widget_text td_block_template_1 widget widget_custom_html"><h4 class="block-title"><span>in case you missed it</span></h4><div class="textwidget custom-html-widget"><div class="bn_twitter_video">
<blockquote class="twitter-tweet" data-lang="en"><p lang="und" dir="ltr"><a href="https://t.co/5n57zJhgcU">https://t.co/5n57zJhgcU</a> <a href="https://twitter.com/hashtag/bitcoincity?src=hash&amp;ref_src=twsrc%5Etfw">#bitcoincity</a> <a href="https://t.co/H1aChovkKE">pic.twitter.com/H1aChovkKE</a></p>&mdash; Bitcoin News (@BTCTN) <a href="https://twitter.com/BTCTN/status/1003681476158816261?ref_src=twsrc%5Etfw">June 4, 2018</a></blockquote>
</div>
</div></aside><aside class="td_block_template_1 widget widget_text">			<div class="textwidget"><p><strong>BTC City – Slovenia’s Largest Shopping Center to Become a ‘Genuine Bitcoin City’.</strong> With over 500 retail shops, BTC City’s website describes itself as “famous for being the largest and most popular European business, shopping, recreational/leisure and cultural center” in the country&#8230; <a href="https://news.bitcoin.com/slovenias-shopping-center-btc-city-genuine-bitcoin-city/">read more</a>.</p>
</div>
		</aside><div class="td-a-rec td-a-rec-id-custom_ad_1  "><div class="ad1">
<!-- BuySellAds PRO Zone Code (News Post Half Page) -->
<div id="bsap_2536" class="bsaPROrocks" data-serve="CKYD62JE" data-segment-placement="news"></div>
<!-- End BuySellAds PRO Zone Code -->
<a href="https://orders.bitcoin.com/">Your Ad Here</a>
</div></div><aside class="widget_text td_block_template_1 widget widget_custom_html"><div class="textwidget custom-html-widget"><div class="td-block-title-wrap">
<h4 class="block-title">
<span class="td-pulldown-size" style="padding-top: 0px;">
Press releases
</span>
</h4>
</div></div></aside><div class="td_block_wrap td_block_3 td_block_widget td_uid_4_5b1702621ad74_rand td-pb-border-top td_block_template_1 td-column-1 td_block_padding"  data-td-block-uid="td_uid_4_5b1702621ad74" ><script>var block_td_uid_4_5b1702621ad74 = new tdBlock();
block_td_uid_4_5b1702621ad74.id = "td_uid_4_5b1702621ad74";
block_td_uid_4_5b1702621ad74.atts = '{"limit":"3","sort":"","post_ids":"","tag_slug":"","autors_id":"","installed_post_types":"","category_id":"341","category_ids":"","custom_title":"","custom_url":"","show_child_cat":"","sub_cat_ajax":"","ajax_pagination":"","header_color":"#","header_text_color":"#","ajax_pagination_infinite_stop":"","td_column_number":1,"td_ajax_preloading":"","td_ajax_filter_type":"","td_ajax_filter_ids":"","td_filter_default_txt":"All","color_preset":"","border_top":"","class":"td_block_widget td_uid_4_5b1702621ad74_rand","el_class":"","offset":"","css":"","tdc_css":"","tdc_css_class":"td_uid_4_5b1702621ad74_rand","live_filter":"","live_filter_cur_post_id":"","live_filter_cur_post_author":"","block_template_id":""}';
block_td_uid_4_5b1702621ad74.td_column_number = "1";
block_td_uid_4_5b1702621ad74.block_type = "td_block_3";
block_td_uid_4_5b1702621ad74.post_count = "3";
block_td_uid_4_5b1702621ad74.found_posts = "699";
block_td_uid_4_5b1702621ad74.header_color = "#";
block_td_uid_4_5b1702621ad74.ajax_pagination_infinite_stop = "";
block_td_uid_4_5b1702621ad74.max_num_pages = "233";
tdBlocksArray.push(block_td_uid_4_5b1702621ad74);
</script><div class="td-block-title-wrap"></div><div id=td_uid_4_5b1702621ad74 class="td_block_inner">

	<div class="td-block-span12">

        <div class="td_module_1 td_module_wrap td-animation-stack">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="https://news.bitcoin.com/pr-gana-technologies-offers-10-bonus-for-joining-cannabis-industry-revolution/" rel="bookmark" title="PR: GANA Technologies Offers 10% Bonus for Joining Cannabis Industry Revolution"><img width="696" height="349" class="entry-thumb" src="https://news.bitcoin.com/wp-content/uploads/2018/06/Gana-logo-1-696x349.png" srcset="https://news.bitcoin.com/wp-content/uploads/2018/06/Gana-logo-1-696x349.png 696w, https://news.bitcoin.com/wp-content/uploads/2018/06/Gana-logo-1-1392x698.png 1392w" sizes="(-webkit-min-device-pixel-ratio: 2) 1392px, (min-resolution: 192dpi) 1392px, 696px" alt="GANA Technologies Offers 10% Bonus for Joining Cannabis Industry Revolution" title="PR: GANA Technologies Offers 10% Bonus for Joining Cannabis Industry Revolution"/></a></div>                            </div>
            <h3 class="entry-title td-module-title"><a href="https://news.bitcoin.com/pr-gana-technologies-offers-10-bonus-for-joining-cannabis-industry-revolution/" rel="bookmark" title="PR: GANA Technologies Offers 10% Bonus for Joining Cannabis Industry Revolution">PR: GANA Technologies Offers 10% Bonus for Joining Cannabis Industry Revolution</a></h3>
            <div class="td-module-meta-info">
                                <span class="td-post-date"><time class="entry-date updated td-module-date" datetime="2018-06-05T13:30:33+00:00" >Jun 5, 2018</time></span>                            </div>

            
        </div>

        
	</div> <!-- ./td-block-span12 -->

	<div class="td-block-span12">

        <div class="td_module_1 td_module_wrap td-animation-stack">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="https://news.bitcoin.com/pr-ethbay-the-new-decentralized-ethereum-marketplace-will-launch-their-ico-on-june-7th/" rel="bookmark" title="PR: Ethbay, the New Decentralized Ethereum Marketplace Will Launch Their ICO on June 7th"><img width="696" height="365" class="entry-thumb" src="https://news.bitcoin.com/wp-content/uploads/2018/06/Ethbay-2-1024x1024-696x365.png" srcset="https://news.bitcoin.com/wp-content/uploads/2018/06/Ethbay-2-1024x1024-696x365.png 696w, https://news.bitcoin.com/wp-content/uploads/2018/06/Ethbay-2-1024x1024-1392x730.png 1392w" sizes="(-webkit-min-device-pixel-ratio: 2) 1392px, (min-resolution: 192dpi) 1392px, 696px" alt="Ethbay, the New Decentralized Ethereum Marketplace Will Launch Their ICO on June 7th" title="PR: Ethbay, the New Decentralized Ethereum Marketplace Will Launch Their ICO on June 7th"/></a></div>                            </div>
            <h3 class="entry-title td-module-title"><a href="https://news.bitcoin.com/pr-ethbay-the-new-decentralized-ethereum-marketplace-will-launch-their-ico-on-june-7th/" rel="bookmark" title="PR: Ethbay, the New Decentralized Ethereum Marketplace Will Launch Their ICO on June 7th">PR: Ethbay, the New Decentralized Ethereum Marketplace Will Launch Their ICO...</a></h3>
            <div class="td-module-meta-info">
                                <span class="td-post-date"><time class="entry-date updated td-module-date" datetime="2018-06-05T05:30:08+00:00" >Jun 5, 2018</time></span>                            </div>

            
        </div>

        
	</div> <!-- ./td-block-span12 -->

	<div class="td-block-span12">

        <div class="td_module_1 td_module_wrap td-animation-stack">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="https://news.bitcoin.com/pr-viola-ai-to-gather-larger-single-women-database/" rel="bookmark" title="PR: Viola.AI To Gather Larger Single Women Database"><img width="696" height="389" class="entry-thumb" src="https://news.bitcoin.com/wp-content/uploads/2018/06/Viola-696x389.png" srcset="https://news.bitcoin.com/wp-content/uploads/2018/06/Viola-696x389.png 696w, https://news.bitcoin.com/wp-content/uploads/2018/06/Viola.png 1392w" sizes="(-webkit-min-device-pixel-ratio: 2) 1392px, (min-resolution: 192dpi) 1392px, 696px" alt="Viola.AI To Gather Larger Single Women Database" title="PR: Viola.AI To Gather Larger Single Women Database"/></a></div>                            </div>
            <h3 class="entry-title td-module-title"><a href="https://news.bitcoin.com/pr-viola-ai-to-gather-larger-single-women-database/" rel="bookmark" title="PR: Viola.AI To Gather Larger Single Women Database">PR: Viola.AI To Gather Larger Single Women Database</a></h3>
            <div class="td-module-meta-info">
                                <span class="td-post-date"><time class="entry-date updated td-module-date" datetime="2018-06-04T13:00:16+00:00" >Jun 4, 2018</time></span>                            </div>

            
        </div>

        
	</div> <!-- ./td-block-span12 --></div></div> <!-- ./block --><aside class="td_block_template_1 widget widget_text">			<div class="textwidget"><a class="btn btn-lg btn-full" href="/submit-press-release">Submit a Press Release</a></div>
		</aside><aside class="widget_text td_block_template_1 widget widget_custom_html"><div class="textwidget custom-html-widget"><div class="td-block-title-wrap">
	<br>
<h4 class="block-title">
<span class="td-pulldown-size" style="padding-top: 0px;">
<b>Latest Comments</b>
</span>
</h4>
</div>
<ul class="bn-dsq-widget-list grey"><li class="bn-dsq-widget-item"><p><b>Kabeer</b></p>
							<span class="bn-dsq-widget-comment">We all know luno headquarters is in UK, but they deliver their service to South Africa, Nigeria,...</span>
							<p class="bn-dsq-widget-meta"><a href="https://news.bitcoin.com/zimbabwes-golix-exchange-enters-kenya-uganda-south-africa/">Zimbabwe’s Golix Exchange Enters Kenya, Uganda, South Africa</a></p><li class="bn-dsq-widget-item"><p><b>branie</b></p>
							<span class="bn-dsq-widget-comment">luno is from the UK</span>
							<p class="bn-dsq-widget-meta"><a href="https://news.bitcoin.com/zimbabwes-golix-exchange-enters-kenya-uganda-south-africa/">Zimbabwe’s Golix Exchange Enters Kenya, Uganda, South Africa</a></p><li class="bn-dsq-widget-item"><p><b>Satoshi Nakamoto</b></p>
							<span class="bn-dsq-widget-comment">Compra Bitcoin, ya!!!!
Satoshi</span>
							<p class="bn-dsq-widget-meta"><a href="https://news.bitcoin.com?p=170059&preview=true&preview_id=170059">Satoshi Nakamoto Revealed: Stylometry & Bootstrapping Proof, Claims UK Nonprofit</a></p><li class="bn-dsq-widget-item"><p><b>Jamie Redman</b></p>
							<span class="bn-dsq-widget-comment">You make a giveaway of Ethereum, have time to take part. In a couple of hours we will post a...</span>
							<p class="bn-dsq-widget-meta"><a href="https://news.bitcoin.com/new-cashpay-wallet-allows-bch-purchases-with-any-online-retailer/">New Cashpay Wallet Allows Purchases With Any Online Retailer Using BCH</a></p><li class="bn-dsq-widget-item"><p><b>Jerome Stonebridge</b></p>
							<span class="bn-dsq-widget-comment">isnt this site in general known to be bitcoin cash biased and whatnot anyways?  they are promoting...</span>
							<p class="bn-dsq-widget-meta"><a href="https://news.bitcoin.com/chinese-wallet-imtoken-holds-20-billion-coinbase-customer-assets/">Chinese Wallet Imtoken Holds $20 Billion in Coinbase Customer Assets</a></p></ul></div></aside><aside class="td_block_template_1 widget widget_media_video"><h4 class="block-title"><span>Roger That!</span></h4><div style="width:100%;" class="wp-video"><!--[if lt IE 9]><script>document.createElement('video');</script><![endif]-->
<video class="wp-video-shortcode" id="video-170366-1" preload="metadata" controls="controls"><source type="video/youtube" src="https://www.youtube.com/watch?v=9TX37-gWFFw&#038;_=1" /><a href="https://www.youtube.com/watch?v=9TX37-gWFFw">https://www.youtube.com/watch?v=9TX37-gWFFw</a></video></div></aside><aside class="td_block_template_1 widget widget_text">			<div class="textwidget"><p><strong>The latest episode of the Bitcoin (BCH) Weekly Roundup.</strong> All the latest Bitcoin news, presented by Roger Ver and Corbin Fraser of Bitcoin.com. Subscribe to our Youtube channel <a href="https://www.youtube.com/c/BitcoincomOfficialChannel">here</a>.</p>
</div>
		</aside><aside class="td_block_template_1 widget widget_media_image"><h4 class="block-title"><span>we are hiring</span></h4><a href="https://news.bitcoin.com/news-bitcoin-com-is-hiring-editorial-staff-in-tokyo-stockholm-and-your-town/"><img width="300" height="300" src="https://news.bitcoin.com/wp-content/uploads/2018/05/hiring-300x300.jpg" class="image wp-image-163956  attachment-medium size-medium" alt="" style="max-width: 100%; height: auto;" srcset="https://news.bitcoin.com/wp-content/uploads/2018/05/hiring-300x300.jpg 300w, https://news.bitcoin.com/wp-content/uploads/2018/05/hiring-150x150.jpg 150w, https://news.bitcoin.com/wp-content/uploads/2018/05/hiring-768x768.jpg 768w, https://news.bitcoin.com/wp-content/uploads/2018/05/hiring-696x696.jpg 696w, https://news.bitcoin.com/wp-content/uploads/2018/05/hiring-420x420.jpg 420w, https://news.bitcoin.com/wp-content/uploads/2018/05/hiring.jpg 800w" sizes="(max-width: 300px) 100vw, 300px" /></a></aside><aside class="td_block_template_1 widget widget_text">			<div class="textwidget"><aside class="td_block_template_1 widget widget_text">
<div class="textwidget">
<p><strong>News.Bitcoin.com is Hiring Editorial Staff – In Tokyo, Stockholm and Your Town.</strong> Are you an experienced news editor or a news reporter with a nose for crypto? We are on a roll – increasing our readership every day – serving millions of readers each month&#8230; <a href="https://news.bitcoin.com/news-bitcoin-com-is-hiring-editorial-staff-in-tokyo-stockholm-and-your-town/">read more.</a></p>
</div>
</aside>
</div>
		</aside><aside class="widget_text td_block_template_1 widget widget_custom_html"><h4 class="block-title"><span>Did You Miss The Tokyo Conference?</span></h4><div class="textwidget custom-html-widget"><a href="https://www.youtube.com/playlist?list=PLpd9yRMC7Ebl40OAmLUI8Zev9Ixekxv6s" target="_blank"><img src="https://news.bitcoin.com/wp-content/uploads/2018/03/satoshis-vision-conference-1392x714.jpg"/></a></div></aside><aside class="td_block_template_1 widget widget_text">			<div class="textwidget"><p>Watch the talks from the <a href="https://www.youtube.com/playlist?list=PLpd9yRMC7Ebl40OAmLUI8Zev9Ixekxv6s">Satoshi’s Vision Conference,</a> that took place in Tokyo, March 23-25.</p>
</div>
		</aside><aside class="td_block_template_1 widget widget_media_image"><h4 class="block-title"><span>Listen to The Bitcoin.com Podcast Network</span></h4><a href="https://podcast.bitcoin.com/"><img width="1280" height="760" src="https://news.bitcoin.com/wp-content/uploads/2018/02/bitcoin-podcast.jpg" class="image wp-image-117699  attachment-full size-full" alt="bitcoin podcast" style="max-width: 100%; height: auto;" srcset="https://news.bitcoin.com/wp-content/uploads/2018/02/bitcoin-podcast.jpg 1280w, https://news.bitcoin.com/wp-content/uploads/2018/02/bitcoin-podcast-300x178.jpg 300w, https://news.bitcoin.com/wp-content/uploads/2018/02/bitcoin-podcast-768x456.jpg 768w, https://news.bitcoin.com/wp-content/uploads/2018/02/bitcoin-podcast-1024x608.jpg 1024w, https://news.bitcoin.com/wp-content/uploads/2018/02/bitcoin-podcast-696x413.jpg 696w, https://news.bitcoin.com/wp-content/uploads/2018/02/bitcoin-podcast-1068x634.jpg 1068w, https://news.bitcoin.com/wp-content/uploads/2018/02/bitcoin-podcast-707x420.jpg 707w" sizes="(max-width: 1280px) 100vw, 1280px" /></a></aside><aside class="widget_text td_block_template_1 widget widget_custom_html"><h4 class="block-title"><span>The Bitcoin.com Wallet: Available on all platforms</span></h4><div class="textwidget custom-html-widget"><div class="bn_twitter_video">
<blockquote class="twitter-tweet" data-lang="en"><p lang="en" dir="ltr">Check out all the latest features and create your wallet today! <a href="https://t.co/CNaJZzHtaZ">https://t.co/CNaJZzHtaZ</a> <a href="https://t.co/huq84amUJG">pic.twitter.com/huq84amUJG</a></p>&mdash; Bitcoin News (@BTCTN) <a href="https://twitter.com/BTCTN/status/983659986487308288?ref_src=twsrc%5Etfw">April 10, 2018</a></blockquote>
</div></div></aside><aside class="td_block_template_1 widget widget_text">			<div class="textwidget"><p>Download the <a href="https://wallet.bitcoin.com/"><strong>Bitcoin.com Wallet</strong></a> right to your device for easy and secure access to your bitcoins. Perfect for beginners, the Bitcoin.com Wallet makes using and holding bitcoins easy. No logins required.</p>
</div>
		</aside><div class="td-a-rec td-a-rec-id-custom_ad_3  "><!-- BuySellAds PRO Zone Code (News Post Half Page) -->
<div id="bsap_2536" class="bsaPROrocks" data-serve="CKYD62JE"></div>
<!-- End BuySellAds PRO Zone Code --></div><aside class="td_block_template_1 widget widget_text">			<div class="textwidget"><div class="btcwdgt-news" bw-entries="10" bw-theme="light" bw-noshadow="true"></div>
<p>Get the latest price charts, statistics and <em>our</em> news feed on <em>your</em> site. Check out our <a href="https://www.bitcoin.com/widgets" target="_new"><u>widget services</u></a>.</p>
<p>&nbsp;</p>
<hr />
</div>
		</aside><aside class="widget_text td_block_template_1 widget widget_custom_html"><div class="textwidget custom-html-widget"><div class="td-block-title-wrap">
<h4 class="block-title">
<span class="td-pulldown-size" style="padding-top: 0px;">
Most Commented This Week
</span>
</h4>
</div>
<div class="bn_most_commented_post_wrapper" data-items-count="1"></div></div></aside><aside class="td_block_template_1 widget widget_text">			<div class="textwidget"><center>
<img src="https://news.bitcoin.com/wp-content/uploads/2016/12/bc-heart-telegram.jpg" width="75%">
</center>
<br>
<p>We also deliver bite-sized news to your favourite messaging app; join our <a href="https://telegram.me/www_Bitcoin_com" target="_new"><u>Telegram channel</u></a>.</p>
<hr></div>
		</aside><aside class="widget_text td_block_template_1 widget widget_custom_html"><div class="textwidget custom-html-widget"><script>
window['bsa_CKYD62QY'] = null;
window['bsa_CKYD62Q7'] = null;
window['bsa_CKYD62JE'] = null;
_bsaPRO_loaded = false;
if (window._bsaPRO) {
    _bsaPRO();
}
</script></div></aside><aside class="widget_text td_block_template_1 widget widget_custom_html"><div class="textwidget custom-html-widget"><div class="td-block-title-wrap">
<h4 class="block-title">
<span class="td-pulldown-size" style="padding-top: 0px;">
Most Popular
</span>
</h4>
</div>
<div class="bn_most_popular_post_wrapper"></div></div></aside>                                </div>
                            </div>
                                    </div> <!-- /.td-pb-row -->
        </article> <!-- /.post --></div></div><div class="alm-btn-wrap"><button class="alm-load-more-btn more ">Older Posts</button></div></div>        
    </div> <!-- /.td-container -->
</div> <!-- /.td-main-content-wrap -->


<!-- Instagram -->



<!-- Footer -->


<!-- Sub Footer -->
</div><!--close td-outer-wrap-->

<div class="td-container">
    <script>var BitcoinMenuWidth = 1400;</script>

    <!-- Join Telegram Pop-up, commented out -->
    <!--
	<div id="join-telegram">
		<a href="https://t.me/www_Bitcoin_com" target="_new">Join our Telegram Channel!</a>
		<p>Get Bitcoin News stories in Telegram</p>
		<a class="dismiss" id="telgram-dismiss" href="#"><i class="td-icon-close-mobile"></i></a>
	</div>
	-->

    <script>
        (function () {
            if (typeof _bsa !== 'undefined' && _bsa) {
                _bsa.init('fancybar', 'CKYDV2QM', 'placement:bitcoincom');
            }
        })();
    </script>
</div>


    <!--

        Theme: Newspaper by tagDiv.com 2017
        Version: 8.0 (rara)
        Deploy mode: deploy
        Speed booster: v4.1

        uid: 5b1702622567a
    -->

    <link rel='stylesheet' id='mediaelement-css'  href='https://news.bitcoin.com/wp-includes/js/mediaelement/mediaelementplayer-legacy.min.css?ver=4.2.6-78496d1' type='text/css' media='all' />
<link rel='stylesheet' id='wp-mediaelement-css'  href='https://news.bitcoin.com/wp-includes/js/mediaelement/wp-mediaelement.min.css?ver=4.9.6' type='text/css' media='all' />
<link rel='stylesheet' id='bn-disqus-latest-comments-css-css'  href='https://news.bitcoin.com/wp-content/plugins/bn-disqus-latest-comments/css/bn-disqus-latest-comments-css.css?ver=2.1.0' type='text/css' media='all' />
<script type='text/javascript'>
/* <![CDATA[ */
var countVars = {"disqusShortname":"bitcoincom"};
/* ]]> */
</script>
<script type='text/javascript' src='https://news.bitcoin.com/wp-content/plugins/disqus-comment-system/public/js/comment_count.js?ver=3.0.15'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var embedVars = {"disqusConfig":{"integration":"wordpress 3.0.15"},"disqusIdentifier":"170366 https:\/\/news.bitcoin.com\/?p=170366","disqusShortname":"bitcoincom","disqusTitle":"Blockchain Developers Abandon Github Following Microsoft Acquisition","disqusUrl":"https:\/\/news.bitcoin.com\/blockchain-developers-abandon-github-following-microsoft-acquisition\/","postId":"170366"};
/* ]]> */
</script>
<script type='text/javascript' src='https://news.bitcoin.com/wp-content/plugins/disqus-comment-system/public/js/comment_embed.js?ver=3.0.15'></script>
<script type='text/javascript' src='https://ajax.googleapis.com/ajax/libs/jquery/1.11.1/jquery.min.js?ver=1.11.1'></script>
<script type='text/javascript' src='https://news.bitcoin.com/wp-content/themes/Newspaper/js/tagdiv_theme.min.js?ver=8.0'></script>
<script type='text/javascript' src='https://news.bitcoin.com/wp-includes/js/comment-reply.min.js?ver=4.9.6'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var globals = {"ajaxurl":"https:\/\/news.bitcoin.com\/wp-admin\/admin-ajax.php","popular_posts_cache_file_url":"https:\/\/news.bitcoin.com\/wp-content\/popular_posts_cache.json","popular_posts_cache_lifetime":"900","most_commented_posts_cache_file_url":"https:\/\/news.bitcoin.com\/wp-content\/most_commented_posts_cache.json","most_commented_posts_cache_lifetime":"120"};
/* ]]> */
</script>
<script type='text/javascript' src='https://news.bitcoin.com/wp-content/themes/BitcoinNews/scripts.min.js?ver=4.9.6'></script>
<script type='text/javascript' src='https://news.bitcoin.com/wp-content/plugins/bootstrap-3.3.7-plugin/js/bootstrap.min.js?ver=4.9.6'></script>
<script type='text/javascript' src='https://widgets.bitcoin.com/widget.js?ver=4.9.6'></script>
<script type='text/javascript' src='https://m.servedby-buysellads.com/monetization.js?ver=4.9.6'></script>
<script type='text/javascript' src='https://menu.cdn.bitcoindotcom.net/the-footer/dist/universal-footer.js?ver=4.9.6'></script>
<script type='text/javascript' src='https://menu.cdn.bitcoindotcom.net/the-menu/dist/universal-menu.js?ver=4.9.6'></script>
<script type='text/javascript' src='https://news.bitcoin.com/wp-includes/js/wp-embed.min.js?ver=4.9.6'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var alm_localize = {"ajaxurl":"https:\/\/news.bitcoin.com\/wp-admin\/admin-ajax.php","alm_nonce":"9bb5c3185c","pluginurl":"https:\/\/news.bitcoin.com\/wp-content\/plugins\/ajax-load-more","scrolltop":"false","ajax_object":{"is_single":true,"is_singular":true}};
/* ]]> */
</script>
<script type='text/javascript' src='https://news.bitcoin.com/wp-content/plugins/ajax-load-more/core/dist/js/ajax-load-more.min.js?ver=3.3.1'></script>
<script type='text/javascript' src='https://news.bitcoin.com/wp-content/plugins/ajax-load-more-previous-post/js/alm-previous-post.min.js?ver=1.2.3'></script>
<script type='text/javascript'>
var mejsL10n = {"language":"en","strings":{"mejs.install-flash":"You are using a browser that does not have Flash player enabled or installed. Please turn on your Flash player plugin or download the latest version from https:\/\/get.adobe.com\/flashplayer\/","mejs.fullscreen-off":"Turn off Fullscreen","mejs.fullscreen-on":"Go Fullscreen","mejs.download-video":"Download Video","mejs.fullscreen":"Fullscreen","mejs.time-jump-forward":["Jump forward 1 second","Jump forward %1 seconds"],"mejs.loop":"Toggle Loop","mejs.play":"Play","mejs.pause":"Pause","mejs.close":"Close","mejs.time-slider":"Time Slider","mejs.time-help-text":"Use Left\/Right Arrow keys to advance one second, Up\/Down arrows to advance ten seconds.","mejs.time-skip-back":["Skip back 1 second","Skip back %1 seconds"],"mejs.captions-subtitles":"Captions\/Subtitles","mejs.captions-chapters":"Chapters","mejs.none":"None","mejs.mute-toggle":"Mute Toggle","mejs.volume-help-text":"Use Up\/Down Arrow keys to increase or decrease volume.","mejs.unmute":"Unmute","mejs.mute":"Mute","mejs.volume-slider":"Volume Slider","mejs.video-player":"Video Player","mejs.audio-player":"Audio Player","mejs.ad-skip":"Skip ad","mejs.ad-skip-info":["Skip in 1 second","Skip in %1 seconds"],"mejs.source-chooser":"Source Chooser","mejs.stop":"Stop","mejs.speed-rate":"Speed Rate","mejs.live-broadcast":"Live Broadcast","mejs.afrikaans":"Afrikaans","mejs.albanian":"Albanian","mejs.arabic":"Arabic","mejs.belarusian":"Belarusian","mejs.bulgarian":"Bulgarian","mejs.catalan":"Catalan","mejs.chinese":"Chinese","mejs.chinese-simplified":"Chinese (Simplified)","mejs.chinese-traditional":"Chinese (Traditional)","mejs.croatian":"Croatian","mejs.czech":"Czech","mejs.danish":"Danish","mejs.dutch":"Dutch","mejs.english":"English","mejs.estonian":"Estonian","mejs.filipino":"Filipino","mejs.finnish":"Finnish","mejs.french":"French","mejs.galician":"Galician","mejs.german":"German","mejs.greek":"Greek","mejs.haitian-creole":"Haitian Creole","mejs.hebrew":"Hebrew","mejs.hindi":"Hindi","mejs.hungarian":"Hungarian","mejs.icelandic":"Icelandic","mejs.indonesian":"Indonesian","mejs.irish":"Irish","mejs.italian":"Italian","mejs.japanese":"Japanese","mejs.korean":"Korean","mejs.latvian":"Latvian","mejs.lithuanian":"Lithuanian","mejs.macedonian":"Macedonian","mejs.malay":"Malay","mejs.maltese":"Maltese","mejs.norwegian":"Norwegian","mejs.persian":"Persian","mejs.polish":"Polish","mejs.portuguese":"Portuguese","mejs.romanian":"Romanian","mejs.russian":"Russian","mejs.serbian":"Serbian","mejs.slovak":"Slovak","mejs.slovenian":"Slovenian","mejs.spanish":"Spanish","mejs.swahili":"Swahili","mejs.swedish":"Swedish","mejs.tagalog":"Tagalog","mejs.thai":"Thai","mejs.turkish":"Turkish","mejs.ukrainian":"Ukrainian","mejs.vietnamese":"Vietnamese","mejs.welsh":"Welsh","mejs.yiddish":"Yiddish"}};
</script>
<script type='text/javascript' src='https://news.bitcoin.com/wp-includes/js/mediaelement/mediaelement-and-player.min.js?ver=4.2.6-78496d1'></script>
<script type='text/javascript' src='https://news.bitcoin.com/wp-includes/js/mediaelement/mediaelement-migrate.min.js?ver=4.9.6'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var _wpmejsSettings = {"pluginPath":"\/wp-includes\/js\/mediaelement\/","classPrefix":"mejs-","stretching":"responsive"};
/* ]]> */
</script>
<script type='text/javascript' src='https://news.bitcoin.com/wp-includes/js/mediaelement/wp-mediaelement.min.js?ver=4.9.6'></script>
<script type='text/javascript' src='https://news.bitcoin.com/wp-includes/js/mediaelement/renderers/vimeo.min.js?ver=4.2.6-78496d1'></script>

<!-- JS generated by theme -->

<script>
    

                jQuery().ready(function jQuery_ready() {
                    tdAjaxCount.tdGetViewsCountsAjax("post","[170366]");
                });
            

	

		(function(){
			var html_jquery_obj = jQuery('html');

			if (html_jquery_obj.length && (html_jquery_obj.is('.ie8') || html_jquery_obj.is('.ie9'))) {

				var path = 'https://news.bitcoin.com/wp-content/themes/BitcoinNews/style.css';

				jQuery.get(path, function(data) {

					var str_split_separator = '#td_css_split_separator';
					var arr_splits = data.split(str_split_separator);
					var arr_length = arr_splits.length;

					if (arr_length > 1) {

						var dir_path = 'https://news.bitcoin.com/wp-content/themes/Newspaper';
						var splited_css = '';

						for (var i = 0; i < arr_length; i++) {
							if (i > 0) {
								arr_splits[i] = str_split_separator + ' ' + arr_splits[i];
							}
							//jQuery('head').append('<style>' + arr_splits[i] + '</style>');

							var formated_str = arr_splits[i].replace(/\surl\(\'(?!data\:)/gi, function regex_function(str) {
								return ' url(\'' + dir_path + '/' + str.replace(/url\(\'/gi, '').replace(/^\s+|\s+$/gm,'');
							});

							splited_css += "<style>" + formated_str + "</style>";
						}

						var td_theme_css = jQuery('link#td-theme-css');

						if (td_theme_css.length) {
							td_theme_css.after(splited_css);
						}
					}
				});
			}
		})();

	
	
</script>


<!-- Header style compiled by theme -->

<style>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</style>


</body>
</html>
<!-- Dynamic page generated in 1.039 seconds. -->
<!-- Cached page generated by WP-Super-Cache on 2018-06-05 17:36:34 -->

<!-- Compression = gzip -->